Understanding GE Carescape Networks

GE Carescape networking and configuration details are provided for the three types of network messages that the Carescape system sends to the Vocera Platform.

GE Carescape Network Traffic

There are three types of network messages which are expected to be received by the Vocera Carescape Adapter:

Time Synchronization (UDP port 2000)

Time messages (UDP port 2000) are sent minimally once per day, and when a time change is initiated on the network.

Occasionally, the master node of the network sends out a time synchronization message.
  • The message is transmitted at least once per day, as well as any time that the system time is changed.
Changing the time on any node within the Carescape network results in the time of all nodes being updated.
  • When a slave node is the point at where the time is changed, it will send a private message to the master node.
  • The master node in turn will broadcast the time synchronization message across the network.
The length of the data within the packets received is consistent across device types.
  • 106 byte packet / 64 bytes data.
Bytes Content
7-10 Consistent for all messages from a single device, but different between devices. This is a hex representation of the IP address of the monitor. The device IP address is used to uniquely identify each device.
25-37 Location identifier. Formatted as <unit>|<room>. The Unit is limited to 7 characters. The Room is limited to 6 characters. If either element is not present at its full length, then the trailing characters of this block are null (00). The location identifier received in the message will be for the master node (the central station).
61-64 Represents the time in seconds since Jan. 1, 1900.

Discovery (UDP port 7000)

Discovery messages (UDP port 7000) are used as a heartbeat to the Vocera appliance to indicate that it is in fact connected to the CARESCAPE Network.

On a regular basis, every node of the Carescape network sends out a discovery message.

The length of the data within the packets received varies by source.

Bytes Content
5-8 Consistent for all messages from a single device, but different between devices. This is a hex representation of the IP address of the monitor. The device IP address is used to uniquely identify each device.
13-25 Location identifier. Formatted as <unit>|<room>. The Unit is limited to 7 characters. The Room is limited to 6 characters. If either element is not present at its full length, then the trailing characters of this block are null (00).
29-41 Patient name, if admitted. Formatted as <last name>,<first name>. If the last name is 13 characters, then the comma is omitted. If the last name is 12 characters, then the last name is 12 characters and the comma is present, but first name is not. If the combination of elements is not present at its full length, then the trailing characters of this block are null (00). Data is only ever present in a message received for patient monitors and when a patient is admitted to the monitor. Patient name is never stored by the adapter.

Alarms (UDP port 7001)

Alarm messages (UDP port 7001) are sent to provide alarm data from monitors/telemetry to be processed by the Vocera appliance and delivered to Cisco wireless handsets.

For the duration of a patient alarm, the patient monitors within the Carescape network will send out an alarm message.

The length of the data within the packets received from all patient monitors is consistent.

Bytes Content
7-10 Consistent for all messages from a single device, but different between devices. This is a hex representation of the IP address of the monitor (e.g., C0A80104 == 192.168.1.4). The device IP address is used to uniquely identify each device.
25-37 Location identifier. Formatted as <unit>|<room>. The Unit is limited to 7 characters. The Room is limited to 6 characters. If either element is not present at its full length, then the trailing characters of this block are null (00).
62

Actual alarm priority. Values include:

  • 07 – High
  • 06 – Medium
  • 05 – Low
  • 03 – Message
67-79 Text of the alarm.
80-84 Duration of the alarm in seconds. Each subsequent message received is incremented. When a paused alarm is resumed, the counter reflects the entire length of the alarm incidence (large increase in the counter since the last message received) as opposed to being reset to zero.

GE Carescape Network Configuration

An alarm router device is required to forward UDP traffic to the new Vocera Communications appliance. The alarm router serves as a one-way connection between the UNITY/Carescape Mission Critical (MC) network and the Vocera Communications appliance that allows broadcast messages on the MC network to be forwarded to an Vocera Communications appliance using broadcast forwarding. No traffic will be sent back to the UNITY/Carescape MC network from the alarm router. The alarm router must be an enterprise-grade router, able to forward UDP traffic and prevent traffic back to the MC network via an ACL.

The alarm router should re-write packets from the Carescape subnet to the Vocera appliance subnet. If the appliance is configured to expect packets on a different broadcast address than the one that the router is forwarding from uses, the appliance will discard the broadcast messages. Configure the NIC on the appliance to match the broadcast address of the Carescape packets sent from the router. The exact method of doing this is determined in the final configuration, depending on if a second NIC is used, and if a router is in between the network and the appliance.

The router and appliance are likely to be on different physical networks, in which case a VLAN can be used to transport the packets across the network from the router to the appliance. If, for any reason, the router cannot re-write the packets to match the main subnet of the appliance, then a second network address that is on the subnet that the router is sending from can be added.

There are three types of GE broadcast messages that the router will forward as unicast to the Vocera appliance:

Network Configuration Example

The following example of network configuration for GE Carescape uses the Cisco 871 router. Traffic between two networks is denied by default; you can explicitly allow traffic to flow between the two networks, if desired.

Router Configuration for test network:
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ext-ge
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
dot11 syslog
ip cef
!
ip domain name ext-inc.com
!
multilink bundle-name authenticated
!
username extension privilege 15 secret 5 $1$.wlA$Mlh02Xn/v8vtm5DX2DY8I1
!
archive
log config
hidekeys
!
ip ssh rsa keypair-name ext-ge.ext-inc.com
ip ssh version 2
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
ip address 10.42.22.10 255.255.255.0
ip helper-address 192.168.1.5
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
!
no ip forward-protocol nd
ip forward-protocol udp 7000
ip forward-protocol udp 7001
ip forward-protocol udp 2000
!
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
logging synchronous
no modem enable
line aux 0
line vty 0 4
login local
!
scheduler max-task-time 5000
end