VMP MS SQL Server Requirements

This table lists the VMP MS SQL Server requirements.

Table 1. SQL server requirements
Item Requirement

MS SQL Server

  • MS SQL Server 2012
  • MS SQL Server 2014

  • MS SQL Server 2016

  • MS SQL Server 2017

  • MS SQL Server 2019

If you have upgraded your SQL server from an older version, you must ensure that the compatibility level for your server is set to 100 (MS SQL Server 2008) or higher.

Database Connectivity

The SQL Server must be configured to enable:

  • Remote Connections

  • TCP/IP

  • Named Pipes

  • SQL Authentication

SQL Instance Name

The SQL Server should be configured with a unique instance to house the VMP SQL database.

Collation (sort order)

SQL_Latin1_General_CP1_CI_AS

The SQL_Latin1_General_CP1_CI_AS collation supports the following capabilities that are required by the Vocera Messaging Platform:
Collation Capability Description
Latin1 Specifies the Latin 1 character set (ASCII)
CP1 Specifies code page 1 (ANSI code page 1252)
CI Specifies case-insensitive sorting, so "ABC" is treated the same as "abc"
AS Specifies accent-sensitive sorting, so "ü" is not treated the same as "u"
Important: In addition to the supported platform requirements, SQL Server System Administrator (SA) credentials are required. The credentials are requested during the installation to connect with the SQL Server during the initial configuration. These credentials are also required for future upgrades.